$re = '/^0+|(?<=\D)0+/';
$str = '03ABCDE
30ABCDE0123
30XY09ZZZ0001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);