import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[])] +)(?P<title>\\w+)(?: +[[【(]|$)";
final String string = "(event) (tag) [group (artist)] title (form) [addition1] [addition2]\n"
+ "(event) [group (artist)] title (form) [addition1]\n"
+ "[event] [group (artist)] title (form) (addition1)\n"
+ "(tag) [group (artist)] title\n"
+ "[group (artist)] title\n"
+ "title\n"
+ "【tag】 [group (artist)] title 【form】\n"
+ "[group (artist)] title\n"
+ "[group] title\n"
+ "[artist] title\n"
+ "(artist) title\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}