$re = '/(?<=XXX)(.*\s*)*\K(aaa)(.*\s*)*\K(?=XXX)/m';
$str = 'aaa
XXX
bbb
aaa
bbb
XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);