re = /(?m)^(?:from[ ]+(\S+)[ ]+)?import[ ]+(\S+)(?:[ ]+as[ ]+\S+)?[ ]*$/
str = 'from abc.lmn import pqr
from abc.lmn import pqr as xyz
import abc
import abc as xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end