$re = '/\[[^\]]*\]/m';
$str = '[foo] [bar] buxx';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;