import re
regex = re.compile(r"\d{2}\/\d{2}\/\d{2} +\K\S+")
test_str = ("SOMEDATA .test 01/45/12 2.50 THIS IS DATA\n"
"SOMEDATA .test 01/45/12 2500 THIS IS DATA\n"
"SOMEDATA .test 01/45/12 $2500 THIS IS DATA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")