$re = '/^first(?=\/|$)/m';
$str = 'firstname
first-and-second
first
first/last
first/second/third
before/first';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);