const regex = new RegExp('<a[^>]+((?<=\\s)href=(\\"|\\\\')([^\\"\\\\']*)(\\\\'|\\")[^>]+(?<=\\s)class=(\\"|\\\\')[^\\\\'\\"]*(?<!\\w|-)obfuscate(?!\\w|-)[^\\\\'\\"]*(\\"|\\\\')|(?<=\\s)class=(\\"|\\\\')[^\\\\'\\"]*(?<!\\w|-)obfuscate(?!\\w|-)[^\\\\'\\"]*(\\"|\\\\')[^>]+(?<=\\s)href=(\\"|\\\\')([^\\"\\\\']*)(\\\\'|\\"))[^>]*>(.*)<\\/a>', 'mis')
const str = `<a nothref="NO-MATCH" notclass="obfuscate" href="test" class="nothing"><abbr>test</abbr></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}