#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[FHD]?[LP]U?\d{3}|H032B|RVS8N"
Local $sString = "BUSS4 Business Flat Line Bundle" & @CRLF & _
"FSULR Ftr Simply Unl LD Bundle" & @CRLF & _
"CC55P Addl Line Basic 2yr Cred n/a Bundle Discount" & @CRLF & _
"FSCC1 Ftr Simply Unl Feat Bundle Discount" & @CRLF & _
"WZC21 LD Discount 24 MO Bundle Discount" & @CRLF & _
"RE099 Additional Line Credit Discount" & @CRLF & _
"RE117 Solutions Bundle Discount Discount" & @CRLF & _
"WZ101 Simply Unlimited Term Discount" & @CRLF & _
"BLSR1 Business Line - Rotary Feature" & @CRLF & _
"CX113 Centranet Feature Package Feature" & @CRLF & _
"IWMB7 Inside Wire Maint - Bus Feature" & @CRLF & _
"OPSN1 Oprtr Call Scrng Inbound Feature" & @CRLF & _
"OVOP4 Onepoint Voice Ma Feature" & @CRLF & _
"VDI03 Unlimited Local Toll n/a Toll" & @CRLF & _
"VDI04 Unlimited Regional toll c n/a Toll" & @CRLF & _
"B1 Business Line " & @CRLF & _
"B1FT3 Business Line - 3 Yr Term " & @CRLF & _
"B1M Business Line - Metered " & @CRLF & _
"CFNT1 CentraNet Stn Ln 2-25 " & @CRLF & _
"CXAM1 CustoPak Ln Measrd Rate " & @CRLF & _
"EUAPB ISDN BRI Interst Acc Port " & @CRLF & _
"FEA1P Addl Line Unl 2 Yr Feat " & @CRLF & _
"IBCD6 ISDN B Channel Voice & Da " & @CRLF & _
"IBRB1 ISDN Single User Access " & @CRLF & _
"ISA06 ISDN BRI Access " & @CRLF & _
"NP Non-Published Listing " & @CRLF & _
"SOLF2 Sol Bun Line 2yr Cpk Feat " & @CRLF & _
"SOLF3 Solutions Feat Pack " & @CRLF & _
"VLC21 Unlimited Local and ZUM c n/a " & @CRLF & _
"WZC70 LEC Discount Bus 24 MO " & @CRLF & _
"" & @CRLF & _
" WZB90 HSI Discount 99 MO Discount" & @CRLF & _
" WZB93 FiOS Internet Bus 99 MO Discount" & @CRLF & _
" WZC66 HSI Discount 24 MO Discount" & @CRLF & _
"MSC03 FiOS Quantum Gateway Rout Equipment" & @CRLF & _
" DL658 High Speed Inet - 7.1/768 " & @CRLF & _
" DP658 High Speed Inet - 7.1/768 " & @CRLF & _
" FL503 FiOSInet 25M/25M 2YR Loop " & @CRLF & _
" FP503 FiOSInet 25M/25M 2YR Port " & @CRLF & _
" H032B FiOS Internet " & @CRLF & _
" HL384 High Speed Inet - 7.1/768 " & @CRLF & _
" HP384 High Speed Inet - 7.1/768 " & @CRLF & _
" LU040 FiOS Internet 25/25 Mb " & @CRLF & _
" PU040 FiOS Internet 25/25 Mb " & @CRLF & _
" RVS8N Online Bkup & Shrng/50GB " & @CRLF & _
"" & @CRLF & _
"VDO03 Unlimited Long Distance n/a" & @CRLF & _
"TTWLD Talk to the World " & @CRLF & _
"VDO04 Unlimited long distance c n/a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")