import re
regex = re.compile(r"^[A-Za-z0-9]{3,8}-[A-Za-z0-9]{3,8}$", flags=re.MULTILINE)
test_str = ("Text-Text\n"
"Abc-123\n"
"123-Abc\n"
"A2C-def4gk\n"
"Ab-3\n"
"Abc!-ajr4\n"
"a-bc3-25aj\n"
"a?c-b%")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")