re = /\{\{((?:(?!{{).)*?)\|(.*?)}}/m
str = 'POWERSTART9^{{2|3}}POWERENDx{{3^EXSTARTxEXEND}}=POWERSTART27^{{1|4}}POWEREND'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end