package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\{([^{}|]*)\|([^{}]*)}}`)
var str = `POWERSTART9^{{2|3}}POWERENDx{{3^EXSTARTxEXEND}}=POWERSTART27^{{1|4}}POWEREND`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}