# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)((?:(?:^[ \t]*)?(?:\\/\*[^*]*\*+(?:[^\\/*][^*]*\*+)*\\/(?:[ \t]*\r?\n(?=[ \t]*(?:\r?\n|\\/\*|\\/\\/|\{)))?|\\/\\/(?:[^\\]|\\(?:\r?\n)?)*?(?:\r?\n(?=[ \t]*(?:\r?\n|\\/\*|\\/\\/|\{))|(?=\r?\n))|\{[\S\s]*?\}(?:[ \t]*\r?\n(?=[ \t]*(?:\r?\n|\\/\*|\\/\\/|\{)))?))+)|((?:"[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|(?:\r?\n(?:(?=(?:^[ \t]*)?(?:\\/\*|\\/\\/|\{))|[^\\/"'\\\r\n{]*))+|[^\\/"'\\\r\n{]+)+|[\S\s][^\\/"'\\\r\n{]*)/$2/g;t' <<< " int j=100;
/* comment needs to be removed*/
int c = 200;
/*
*comment needs to be removed
*/
count = count + 1;
{comment needs to be removed}
i++;"