package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[_a-z0-9-]+(\.[_a-z0-9-]+)*@[a-z0-9-]+(\.[a-z0-9-]+)*(\.[a-z]{2,3})`)
var str = `<html>
<body>
<p>abc123@sdsd.com</p>
</body>
</html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}