$re = '/([0-9]*)([\.[0-9]+)(]?)([^0-9]*)D(\([M|W]\))(\s*US)/';
$str = '9.5 D(M) US';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);