$re = '/(?<!^)(?=\D)|(?<=\D)/';
$str = 'x^(24-3x)';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;