package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w\s]`)
var str = `17:34:12:p. m.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}