using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=GET |POST )\s*.*?(?= |\?)";
string input = @"-- ""GET /fss-w3-mtpage.php HTTP/1.1"" 200 0.084 41 ""-"" ""c110bc/1.0"" 127.0.0.1:25001 0.084
-- ""GET /m/firstpage/Services/getAll?ids=ABCVDFDS,ASDASBDB,ASDBSA&requestId=091fa2b4-643e-4473-b6d8-40210b775dcf HTTP/1.1"" 200
-- POST /lastpage/Services/getAll?ids=ABCVDFDS,ASDASBDB,ASDBSA&requestId=091fa2b4-643e-4473-b6d8-40210b775dcf HTTP/1.1"" 200";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}