#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((?:[^\n][\n]?)+)"
Local $sString = "Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod" & @CRLF & _
"tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At" & @CRLF & _
"vero eos et accusam et justo duo dolores et ea rebum. " & @CRLF & _
"" & @CRLF & _
"Stet clita kasd gubergren," & @CRLF & _
"no sea takimata sanctus est Lorem ipsum dolor sit amet." & @CRLF & _
"" & @CRLF & _
"Ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod" & @CRLF & _
"tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At" & @CRLF & _
"vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren," & @CRLF & _
"no sea takimata sanctus est Lorem ipsum dolor sit amet."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")