$re = '/^[a-zA-Z]{2}\*[0-9]{5}$/';
$str = 'az*12345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);