$re = '/([0-9]++)((?:,[0-9]++)*+)/';
$str = '31,5,46,7,86';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);