re = /^([-!#$%&'*+\/=?^_`{}|~0-9a-zA-Z]+(\.[-!#$%&'*+\/=?^_`{}|~0-9a-zA-Z]+)*|^"([\001-\010\013\014\016-\037!#-\[\]-\177]|\\[\001-011\013\014\016-\177])*")@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?\.)+[a-zA-Z]{2,6}\.?$/
str = 'da.ni.el@l.ev.ire.cc'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result