$re = '/^[1-9]|0$/';
$str = '00000000000000000000000000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);