re = /^(?=([A-Za-z0-9]|[^\x00-\x7F])([A-Za-z0-9@._%+-]|[^\x00-\x7F]){5,253}$)([A-Za-z0-9._%+-]|[^\x00-\x7F]){1,64}@(?:(?=([A-Za-z0-9-]|[^\x00-\x7F]){1,63}\.)([A-Za-z0-9]|[^\x00-\x7F])+(?:-([A-Za-z0-9]|[^\x00-\x7F])+)*\.){1,8}([A-Za-z]|[^\x00-\x7F]){2,63}$/m
str = 'Format: minimum 2 characters @ minimum 3 characters . 2 - 63 characters
the g modifier let\'s us match multiple times in one string. the m modifier is useful here because it lets us treat each line as a seperate entry. Though in practice you probably dont need it for a simple one line email field
^(?=[A-Z0-9][A-Z0-9@._%+-]{5,253}+$)[A-Z0-9._%+-]{1,64}+@(?:(?=[A-Z0-9-]{1,63}+\\.)[A-Z0-9]++(?:-[A-Z0-9]++)*+\\.){1,8}+[A-Z]{2,63}+$
שדגכ@שדגכ
דגכ
אלפ@גכדץ.בםצ
Jim@stuff.co.uk
Jim@google.com
Henry@h.com
Joe @m.net
Joe@m.net
Joe@mo.net
Joe@sam.net
a@sam.net
mo@sam.org
12@sam.org
Jon@sam.c
Jon@sam.co
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end