package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^a-z]+)`)
var str = `MOC.OOHAY@ABC.PQRqwertySDdd
MOC.OOHAY@AB.JKLasDDbfn
MOC.OOHAY@XZ.JKGposDDbfn
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}