$re = '/(?i)(E[^-]?\d+\.\d+(?=[^G\d]))((.*?)G[0-3]{1,3}[X](?P<x>\d+\.\d+)[Y](?P<y>\d+\.\d+)[E](?P<e>\d+\.\d+))+/';
$str = 'G1Z34.250G1E0.80000F2100.00000M204S2000G1F3600G1X116.347Y114.919E0.19149M204S1000G1F5760G1X116.915Y112.800E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X116.444Y115.944G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X117.226Y115.161E0.03012G1X116.617Y115.153E0.01657G1X116.028Y115.742E0.02268G1X115.430Y115.723E0.01628G1X116.008Y115.144E0.02225G1X115.457Y115.078E0.01511G1X114.981Y115.555E0.01835G1X114.653Y115.266E0.01190G1X115.021Y114.898E0.01416G1X114.974Y114.870E0.00147G1X114.544Y114.757E0.01210G1X113.978Y115.324E0.02182G1X113.509Y115.532E0.01397G1X113.427Y115.257E0.00779G1X114.037Y114.647E0.02349M204S1000G1X113.577Y114.779F7200.000M204S2000G1F3600G1X113.261Y114.463E0.01165G1X113.241Y114.304E0.00420G1X113.698Y114.294E0.01190G1X113.798Y113.068E0.03204G1X113.945Y112.095E0.02564G1X114.045Y111.652E0.01184G1X114.231Y111.001E0.01763G1X114.541Y110.120E0.02434G1X114.894Y109.388E0.02118G1X115.597Y108.634E0.02687G1X116.029Y108.368E0.01320G1X119.844Y112.183E0.14058M204S1000G1F5760G1X118.292Y110.632E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X117.458Y113.907G1Z34.250G1E0.80000F2100.00000M204S2000G1F3600G1X114.861Y114.602E0.07006M204S1000G1F5760G1X116.981Y114.035E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X113.550Y113.282G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X113.164Y113.669E0.01488G1X113.140Y113.076E0.01616G1X113.416Y112.799E0.01065G1X113.526Y112.072E0.02001G1X113.148Y112.450E0.01454G1X113.202Y111.779E0.01832G1X113.723Y111.258E0.02006G1X113.833Y110.874E0.01086G1X114.019Y110.344E0.01529G1X113.308Y111.055E0.02736G1X113.474Y110.272E0.02178G1X116.942Y106.805E0.13347G1X117.539Y106.825E0.01626G1X116.747Y107.617E0.03048G1X117.430Y107.551E0.01868G1X118.174Y106.807E0.02862G1X118.809Y106.789E0.01729G1X118.043Y107.555E0.02948G1X118.577Y107.639E0.01470G1X119.284Y106.931E0.02724G1X119.765Y107.067E0.01360G1X119.102Y107.731E0.02554G1X119.400Y107.777E0.00823G1X119.590Y107.860E0.00563G1X120.173Y107.277E0.02243G1X120.252Y107.377E0.00346G1X120.246Y107.476E0.00271G1X119.759Y108.005E0.01955G1X119.774Y108.292E0.00784G1X118.910Y109.157E0.03327G1X118.691Y109.524E0.01164G1X118.734Y109.649E0.00357G1X118.950Y109.734E0.00633G1X119.805Y108.879E0.03291G1X119.836Y109.465E0.01598G1X119.393Y109.908E0.01705G1X119.836Y110.083E0.01295G1X120.100Y109.819E0.01017G1X120.519Y110.016E0.01262G1X120.003Y110.533E0.01989G1X120.089Y110.912E0.01057G1X120.102Y111.051E0.00380G1X120.679Y110.474E0.02219G1X120.779Y110.991E0.01432G1X120.150Y111.621E0.02425G1X120.068Y112.246E0.01716G1X120.037Y112.350E0.00295G1X120.817Y111.570E0.03000G1X120.803Y111.765E0.00531G1X120.651Y112.354E0.01654G1X117.042Y115.963E0.13893M204S1000G1X117.729Y115.893F7200.000M204S2000G1F3000G1X118.646Y114.976E0.03529M204S1000G1F5760G1X117.729Y115.893E-0.44908G1E-0.35092F2100.00000G1Z34.850F7200.000G1X117.486Y114.901G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X119.002Y113.386E0.05834G1X118.897Y113.408E0.00292G1X118.624Y113.555E0.00844G1X118.036Y113.735E0.01674G1X117.495Y114.275E0.02081M204S1000G1F5760G1X118.036Y113.735E-0.26489G1X118.624Y113.555E-0.21299G1X118.897Y113.408E-0.10742G1X119.002Y113.386E-0.03711G1X118.721Y113.667E-0.13760G1E-0.04000F2100.00000G1Z34.850F7200.000G1X113.421Y109.708G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X116.438Y106.692E0.11612M204S1000G1X115.610Y106.902F7200.000M204S2000G1F3000G1X113.858Y108.654E0.06742M204S1000G1F5760G1X115.410Y107.103E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X120.151Y90.503G1Z34.250G1E0.80000F2100.00000M204S800G1F1200G1X120.079Y91.880E0.03592G1X120.533Y92.374E0.01747G1X120.554Y92.437E0.00174G1X120.573Y92.703E0.00693G1X120.570Y92.731E0.00076G1X120.325Y93.051E0.01050G1X119.981Y93.207E0.00985G1X118.863Y93.526E0.03027G1X117.422Y93.485E0.03758G1X116.915Y93.510E0.01320G1X115.860Y93.344E0.02784G1X115.670Y93.270E0.00532G1X115.125Y92.985E0.01602G1X114.908Y92.831E0.00693G1X114.655Y92.599E0.00894G1X114.277Y92.170E0.01489G1X113.949Y91.729E0.01433G1X113.580Y91.137E0.01818G1X113.393Y90.630E0.01408G1X113.236Y90.117E0.01399G1X112.970Y88.861E0.03344G1X112.845Y87.819E0.02735G1X112.821Y87.286E0.01390G1X112.823Y86.758E0.01377G1X112.853Y86.270E0.01273G1X113.008Y85.139E0.02976G1X113.155Y84.536E0.01616G1X113.342Y83.995E0.01492G1X113.379Y84.048E0.00169G1X114.371Y84.567E0.02918G1X115.010Y84.011E0.02206G1X115.358Y83.966E0.00913G1X116.534Y83.909E0.03069G1X117.333Y83.900E0.02083G1X117.799Y83.991E0.01235G1X118.097Y84.135E0.00863G1X118.534Y84.474E0.01440G1X119.172Y85.317E0.02755G1X119.351Y85.748E0.01216G1X119.931Y86.317E0.02117G1X120.425Y86.611E0.01497G1X120.633Y86.865E0.00856G1X120.918Y87.442E0.01676G1X121.119Y88.189E0.02015G1X121.162Y88.730E0.01416G1X121.005Y89.557E0.02194G1X120.785Y90.205E0.01782G1X120.206Y90.478E0.01669M204S1000G1X120.555Y90.775F7200.000M204S800G1F1200G1X120.506Y91.727E0.02483G1X120.901Y92.157E0.01523G1X120.967Y92.355E0.00545G1X120.992Y92.706E0.00916G1X120.976Y92.889E0.00479G1X120.593Y93.389E0.01640G1X120.123Y93.602E0.01345G1X119.212Y93.849E0.02460G1X118.926Y93.946E0.00785G1X117.426Y93.903E0.03910G1X116.893Y93.930E0.01390G1X115.750Y93.750E0.03014G1X115.497Y93.651E0.00710G1X114.906Y93.342E0.01737G1X114.645Y93.156E0.00834G1X114.356Y92.892E0.01019G1X113.953Y92.434E0.01593G1X113.603Y91.965E0.01523G1X113.203Y91.321E0.01974G1X112.997Y90.764E0.01549G1X112.827Y90.208E0.01513G1X112.559Y88.935E0.03390G1X112.480Y88.364E0.01501G1X112.428Y87.849E0.01349G1X112.403Y87.295E0.01447G1X112.406Y86.744E0.01434G1X112.437Y86.229E0.01344G1X112.597Y85.060E0.03074G1X112.753Y84.422E0.01712G1X112.932Y83.870E0.01512G1X113.136Y83.512E0.01074G1X113.296Y83.366E0.00563G1X113.375Y83.322E0.00236G1X113.661Y83.724E0.01285G1X114.312Y84.065E0.01915G1X114.805Y83.636E0.01703G1X114.917Y83.602E0.00303G1X115.321Y83.550E0.01061G1X116.522Y83.491E0.03134G1X117.372Y83.482E0.02215G1X117.931Y83.592E0.01485G1X118.318Y83.777E0.01118G1X118.834Y84.178E0.01701G1X119.392Y84.894E0.02366G1X119.542Y85.120E0.00706G1X119.704Y85.509E0.01100G1X120.188Y85.983E0.01765G1X120.701Y86.289E0.01558G1X120.987Y86.637E0.01172G1X121.311Y87.294E0.01908G1X121.533Y88.117E0.02222G1X121.583Y88.753E0.01663G1X121.410Y89.664E0.02416G1X121.145Y90.444E0.02146G1X121.045Y90.544E0.00368G1X120.610Y90.749E0.01255M204S1000G1X120.960Y91.046F7200.000M204S800G1F1200G1X120.932Y91.573E0.01374G1X121.269Y91.940E0.01299G1X121.380Y92.273E0.00916G1X121.411Y92.710E0.01139G1X121.382Y93.047E0.00882G1X120.861Y93.726E0.02231G1X120.265Y93.996E0.01705G1X119.333Y94.249E0.02515G1X118.989Y94.365E0.00947G1X117.430Y94.322E0.04062G1X116.871Y94.349E0.01460G1X115.641Y94.156E0.03244G1X115.323Y94.032E0.00888G1X114.687Y93.699E0.01873G1X114.382Y93.482E0.00975G1X114.058Y93.186E0.01144G1X113.628Y92.697E0.01696G1X113.258Y92.200E0.01613G1X112.826Y91.506E0.02131G1X112.601Y90.897E0.01691G1X112.418Y90.300E0.01628G1X112.389Y90.097E0.00533G1X112.147Y89.009E0.02904G1X112.065Y88.414E0.01566G1X112.011Y87.880E0.01399G1X111.985Y87.303E0.01505G1X111.988Y86.730E0.01492G1X112.021Y86.188E0.01416G1X112.186Y84.982E0.03172G1X112.351Y84.308E0.01808G1X112.547Y83.701E0.01663G1X112.805Y83.248E0.01359G1X113.050Y83.025E0.00863G1X113.276Y82.899E0.00672G1X113.485Y82.907E0.00547G1X113.642Y82.978E0.00447G1X113.944Y83.400E0.01352G1X114.253Y83.562E0.00911G1X114.599Y83.262E0.01193G1X114.829Y83.192E0.00627G1X115.283Y83.133E0.01194G1X116.509Y83.074E0.03198G1X117.410Y83.064E0.02347G1X118.064Y83.192E0.01736G1X118.539Y83.420E0.01373G1X119.134Y83.882E0.01962G1X119.624Y84.531E0.02119G1X119.720Y84.633E0.00366G1X119.912Y84.922E0.00904G1X120.057Y85.271E0.00984G1X120.445Y85.650E0.01413G1X120.978Y85.968E0.01618G1X121.340Y86.409E0.01487G1X121.703Y87.146E0.02140G1X121.946Y88.046E0.02429G1X122.004Y88.776E0.01910G1X121.815Y89.771E0.02638G1X121.510Y90.670E0.02474G1X121.290Y90.891E0.00812G1X121.014Y91.021E0.00794M204S1000G1X120.565Y91.112F7200.000G1F5760G1X120.932Y91.573E-0.19337G1X121.269Y91.940E-0.17262G1X121.380Y92.273E-0.12171G1X121.411Y92.710E-0.15143G1X121.382Y93.047E-0.11721G1X121.375Y93.055E-0.00365G1E-0.04000F2100.00000G1Z34.850F7200.000G1X119.281Y91.835G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X119.795Y91.322E0.01928G1X119.828Y90.686E0.01691G1X119.194Y91.320E0.02382G1X118.969Y90.943E0.01167G1X120.764Y89.148E0.06740G1X120.846Y88.713E0.01177G1X120.828Y88.481E0.00617G1X120.053Y89.256E0.02912G1X120.106Y89.069E0.00518G1X120.150Y88.557E0.01364G1X120.736Y87.971E0.02203G1X120.600Y87.505E0.01290G1X120.101Y88.004E0.01874G1X120.064Y87.745E0.00694G1X120.000Y87.502E0.00667G1X120.401Y87.102E0.01504G1X120.368Y87.036E0.00195G1X120.217Y86.852E0.00632G1X120.111Y86.789E0.00329G1X119.839Y87.061E0.01023G1X119.764Y86.937E0.00385G1X119.517Y86.780E0.00776G1X119.735Y86.563E0.00816G1X119.430Y86.265E0.01132G1X119.070Y86.626E0.01355G1X118.887Y86.527E0.00552G1X118.641Y86.452E0.00682G1X119.126Y85.967E0.01823G1X119.086Y85.927E0.00149G1X118.932Y85.558E0.01063G1X118.179Y86.311E0.02831G1X117.868Y86.217E0.00864G1X117.815Y86.159E0.00207G1X117.800Y86.088E0.00195G1X118.689Y85.199E0.03339G1X118.430Y84.856E0.01142G1X117.696Y85.590E0.02757G1X117.592Y85.091E0.01352G1X118.128Y84.555E0.02014G1X117.932Y84.403E0.00660G1X117.760Y84.321E0.00505G1X117.242Y84.839E0.01946G1X116.631Y84.847E0.01622G1X117.264Y84.215E0.02376G1X116.655Y84.221E0.01618G1X116.021Y84.855E0.02383G1X115.336Y84.937E0.01831G1X116.026Y84.247E0.02591G1X115.393Y84.278E0.01684G1X114.390Y85.281E0.03768G1X114.338Y85.280E0.00138G1X113.943Y85.126E0.01127G1X114.225Y84.844E0.01059G1X113.829Y84.637E0.01185G1X113.316Y85.150E0.01928M204S1000G1F5760G1X113.829Y84.637E-0.25140G1X114.225Y84.844E-0.15456G1X113.943Y85.126E-0.13810G1X114.338Y85.280E-0.14693G1X114.390Y85.281E-0.01803G1X114.494Y85.177E-0.05097G1E-0.04000F2100.00000G1Z34.850F7200.000G1X112.951Y86.720G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X113.326Y86.345E0.01408G1X113.374Y86.900E0.01479G1X113.135Y87.139E0.00897G1X113.154Y87.722E0.01550G1X113.442Y87.434E0.01083G1X113.529Y87.950E0.01390G1X113.205Y88.273E0.01215G1X113.279Y88.802E0.01419G1X113.641Y88.440E0.01363G1X113.770Y88.913E0.01303G1X113.384Y89.300E0.01453G1X113.489Y89.797E0.01350G1X113.918Y89.368E0.01612G1X114.075Y89.813E0.01255G1X113.613Y90.275E0.01737G1X113.763Y90.727E0.01265G1X114.252Y90.238E0.01836G1X114.449Y90.643E0.01197G1X113.952Y91.141E0.01869G1X114.183Y91.512E0.01162G1X114.690Y91.005E0.01904G1X114.980Y91.317E0.01132G1X114.437Y91.860E0.02040G1X114.711Y92.189E0.01136G1X115.271Y91.629E0.02103G1X115.448Y91.778E0.00614G1X115.624Y91.878E0.00539G1X115.006Y92.496E0.02321G1X115.289Y92.718E0.00955G1X115.353Y92.751E0.00192G1X116.008Y92.097E0.02459G1X116.412Y92.296E0.01195G1X115.749Y92.958E0.02489G1X115.942Y93.040E0.00557G1X116.225Y93.085E0.00761G1X116.902Y92.407E0.02545G1X117.463Y92.449E0.01493G1X116.746Y93.166E0.02695G1X116.932Y93.196E0.00502G1X117.339Y93.176E0.01081G1X118.077Y92.437E0.02774G1X118.790Y92.326E0.01918G1X117.931Y93.186E0.03230G1X118.517Y93.203E0.01557G1X119.761Y91.958E0.04677G1X119.759Y91.995E0.00100G1X120.031Y92.291E0.01066G1X118.951Y93.371E0.04057M204S1000G1F5760G1X120.031Y92.291E-0.52898G1X119.759Y91.995E-0.13894G1X119.761Y91.958E-0.01303G1X119.600Y92.119E-0.07906G1E-0.04000F2100.00000G1Z34.850F7200.000G1X117.606Y92.219G1Z34.250G1E0.80000F2100.00000M204S2000G1F3600G1X113.893Y88.506E0.13683M204S1000G1X114.000Y88.880F7200.000M204S2000G1F3600G1X119.709Y87.351E0.15400M204S1000G1F5760G1X117.590Y87.918E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X117.574Y86.127G1Z34.250G1E0.80000F2100.00000M204S2000G1F3600G1X116.040Y91.851E0.15439M204S1000G1F5760G1X116.608Y89.731E-0.76000G1E-0.04000F2100.00000G1Z34.850F7200.000G1X118.607Y90.702G1Z34.250G1E0.80000F2100.00000M204S2000G1F3000G1X119.438Y89.872E0.03119M204S1000;BEFORE_LAYER_CHANGE;34.4G1F5760G1X118.607Y90.702E-0.40665G1E-0.39335F2100.00000G1Z34.850';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);