$re = '/\b(?![01]*([01])\1{4})[01]+\b/m';
$str = '001111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);