re = /\b[a-f0-9]{2}(?:([:-]?)[a-f0-9]{2}(?:\1[a-f0-9]{2}){4}|(?:\.?[a-f0-9]{2}){5})\b/i
str = 'Jun 16 10:24:28 (2248) Login OK: cli 88-c9-d0-fd-13-65 via TLS tunnel)
Jun 16 10:24:35 (2258) Login OK: cli f8:a9:d0:72:0a:dd via TLS tunnel)
Jun 16 10:24:44 (2273) Login OK: cli 485a.3f12.a35a via TLS tunnel)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end