import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(|([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\\w\\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>)((\\s*\\,\\s*)([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\\w\\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>))*)$";
        final String string = "Hello <ABC@ABa.COM>, Hi<a@b.com>";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}