$re = '/<a(.*?)>(.*?)<\/a>/';
$str = '<String id="blah"><a href="#" class="btn">Download</a></String>';
$subst = "<a$1>$2</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;