$re = '/\D+/';
$str = '€ 1.250.000 k.k.
€ 359.000 k.k.
€ 89.000 v.o.n.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;