# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!-)((\d+(\.\d+)?))(\s*[xX]\s*\d+(\.\d+)?){1,2}\s*(mm|cm|mtrs|ft|yd)"
test_str = ("120x200mm matches\n"
"12.2x200.3mtrs matches\n"
"2x21x21cm // needs to match\n\n"
"100\\' X 130\\'\n"
"4 acres\n"
"0.54\n"
"0.488 (90x223)/ GIS0.78\n"
"90x160\n"
"100x149.7x123\n"
"143.76 X 453.52\n"
"6.13 per tax bill\n"
"120x378 per tax roll")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.