$re = '/^L1(?:,(\d+)){3}/';
$str = 'L1,3,5,0,5,80,40,31,0,0,0,0,512,412,213,900';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);