import re
regex = re.compile(r"((?:.*?)([0-9]{5})(.*?)(?: {7,})(.*?)(?: {3,})(.*?)(?: {3,})(.*?)(\\.*?)(?![0-9\\]{6})(Quartal.*?)?(?=[0-9]{5}|Stand)(?:.*?))", flags=re.IGNORECASE)
test_str = ("Kassenärztliche Bundesvereinigung KBV\\n\\n\\n\\n GOP\\n 1) Kurzlegende Kalkulations- Prüfzeit Eignung der\\n zeit in in Prüfzeit\\n Minuten\\n 2) Minuten\\n\\n 01100 Unvorhergesehene KA ./. Keine Eignung\\n Inanspruchnahme I\\n 01101 Unvorhergesehene KA ./. Keine Eignung\\n Inanspruchnahme II\\n 01102 Inanspruchnahme an Samstagen KA ./. Keine Eignung\\n 01205 Notfallpauschale (Abklärung, 2 ./. Keine Eignung\\n Koordination I)\\n 01207 Notfallpauschale (Abklärung, 2 ./. Keine Eignung\\n Koordination II)\\n 01210 Notfallpauschale I KA ./. Keine Eignung\\n 01212 Notfallpauschale II KA ./. Keine Eignung\\n 01214 Notfallkonsultationspauschale I KA ./. Keine Eignung\\n 01216 Notfallkonsultationspauschale II KA ./. Keine Eignung\\n 01218 Notfallkonsultationspauschale III KA ./. Keine Eignung\\n 01220 Reanimationskomplex KA ./. Keine Eignung\\n 01221 Zuschlag Beatmung KA ./. Keine Eignung\\n 01222 Zuschlag Defibrillation KA ./. Keine Eignung\\n 01223 Zuschlag Notfallpauschale zur GOP KA ./. Keine Eignung\\n 01210\\n 01224 Zuschlag Notfallpauschale zur GOP KA ./. Keine Eignung\\n 01212\\n 01226 Zuschlag Notfallpauschale zur GOP KA ./. Keine Eignung\\n 01212\\n 01320* Grundpauschale I für ermächtigte KA 6 Nur\\n Ärzte, Institute und Krankenhäuser Quartalsprofil\\n 01321* Grundpauschale II für ermächtigte KA 11 Nur\\n Ärzte, Institute und Krankenhäuser Quartalsprofil\\n 01322 Zuschlag TSS-Terminvermittlung KA ./. Keine Eignung\\n oder Hausarztvermittlungsfall\\n 01323 Zuschlag TSS-Terminvermittlung KA ./. Keine Eignung\\n oder Hausarztvermittlungsfall\\n 01410 Besuch KA 13 Tages- und\\n Quartalsprofil\\n 01411 Dringender Besuch I KA ./. Keine Eignung\\n 01412 Dringender Besuch II KA ./. Keine Eignung\\n 01413 Besuch eines weiteren Kranken KA 6 Tages- und\\n Quartalsprofil\\n 01414* Visite auf der Belegstation, je KA ./. Keine Eignung\\n Patient\\n 01415 Dringender Besuch eines KA ./. Keine Eignung\\n Patienten in beschützenden\\n Wohnheimen bzw. Einrichtungen\\n\\n\\n\\nStand 1/2025, erstellt am 10.02.2025 Seite 1279 von 1430\\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")