import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*[A-Z]+(?: [A-Z0-9-]+)+[ \\t]+[0-9]{7}[ \\t]+.*(?:\\r?\\n(?![ \\t]*$).*)*";
final String string = "\n\n\n\n"
+ " DATE: 02 July 2019 \n\n\n"
+ " -------------------------------------------------------------------------------------------- \n"
+ " WELL NAME LICENCE NUMBER MINERAL RIGHTS GROUND ELEVATION \n"
+ " UNIQUE IDENTIFIER SURFACE CO-ORDINATES BOARD FIELD CENTRE PROJECTED DEPTH \n"
+ " LAHEE CLASSIFICATION FIELD TERMINATING ZONE \n"
+ " DRILLING OPERATION WELL PURPOSE WELL TYPE SUBSTANCE \n"
+ " LICENSEE SURFACE LOCATION \n"
+ " -------------------------------------------------------------------------------------------- \n\n"
+ " MEG K7N HARDY 4-7-77-5 0483923 ALBERTA CROWN 571.7M \n"
+ " 106/04-07-077-05W4/02 S 572.4M W 278.3M BONNYVILLE 1600.0M \n"
+ " DEV (NC) HARDY MCMURRAY FM \n"
+ " HORIZONTAL RESUMPTIONPRODUCTION (SCHEME) CRUDE BITUMEN \n"
+ " MEG ENERGY CORP. 09-07-077-05W4 \n\n"
+ " SPL 11-24 HZ MARTEN 14-25-76-6 0494994 ALBERTA CROWN 705.3M \n"
+ " 100/14-25-076-06W5/00 S 566.0M E 800.6M ST. ALBERT 2700.0M \n"
+ " OUT (C) MARTEN CLEARWATER FM \n"
+ " HORIZONTAL NEW PRODUCTION CRUDE OIL \n"
+ " SPUR PETROLEUM LTD. 11-24-076-06W5 \n\n"
+ " SPL 10-24 HZ MARTEN 5-23-76-6 0494995 ALBERTA CROWN 705.5M \n"
+ " 100/05-23-076-06W5/00 S 566.3M W 800.1M ST. ALBERT 2700.0M \n"
+ " OUT (C) MARTEN CLEARWATER FM \n"
+ " HORIZONTAL NEW PRODUCTION CRUDE OIL \n"
+ " SPUR PETROLEUM LTD. 10-24-076-06W5 \n\n"
+ " SURGE ENERGY HZ103 VALHALLA 6-7-75-8 0494996 ALBERTA CROWN 770.8M \n"
+ " 103/06-07-075-08W6/00 S 372.0M E 324.5M GRANDE PRAIRIE 3350.0M \n"
+ " DEV (NC) VALHALLA DOIG FM \n"
+ " HORIZONTAL NEW PRODUCTION CRUDE OIL \n"
+ " SURGE ENERGY INC. 13-06-075-08W6 \n\n"
+ " CNRL ET AL HZ KARR 4-16-66-3 0494997 ALBERTA CROWN 770.7M \n"
+ " 100/04-16-066-03W6/00 N 623.4M E 127.5M GRANDE PRAIRIE 5295.0M \n"
+ " DEV (NC) KARR DUNVEGAN FM \n"
+ " HORIZONTAL NEW PRODUCTION CRUDE OIL \n"
+ " CANADIAN NATURAL RESOURCES LIMITED 05-14-066-03W6 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}