$re = '/^[a-z_]([a-z0-9_-]+\.){2,}[a-z0-9_-]+$/m';
$str = 'dev.blek.logo
dd.dfg.logo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);