$re = '/(?<=:)(.*)(?=:)/';
$str = 'My-Test:abc,def,ghi,jkl:12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);