#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\"Flesh)|^(?:\"Primitive)|^(?:\"Mutant)|^(?:\"Sacred)|^(?:\"Super)|^(?:\"Meat of)"
Local $sString = "" & @CRLF & _
""Black beetle killed. No beast soul gained. Eat the flesh of the black beetle to gain zero to ten geno points randomly."" & @CRLF & _
""Black beetle flesh eaten. Zero geno points gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Primitive creature green-scaled beast killed. No beast soul gained. Eat the flesh of the primitive green-scaled beast to gain zero to ten points randomly."" & @CRLF & _
""Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten points randomly."" & @CRLF & _
""Primitive creature swift mantis killed …"" & @CRLF & _
""Primitive creature copper-toothed beast killed. No beast soul gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Primitive creature copper-toothed beast killed. Primitive beast soul of copper-toothed beast gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Sacred-blood bloody slayer killed. Sacred-blood beast soul bloody slayer gained. Eat the flesh of bloody slayer to gain zero to ten sacred geno points randomly."" & @CRLF & _
""Primitive green-scaled beast flesh eaten. One primitive geno point gained."" & @CRLF & _
""Mutant copper-toothed beast killed. No beast soul gained. Eat its flesh to gain zero to ten mutant geno points."" & @CRLF & _
""Mutant copper-toothed beast flesh eaten. One mutant geno point gained."" & @CRLF & _
""Primitive creature quartz scorpion killed. No beast soul gain. Eat the flesh of quartz scorpion to gain zero to ten primitive geno points."" & @CRLF & _
""Primitive quartz scorpion flesh eaten. Four primitive geno points gained."" & @CRLF & _
""Young obsidian dragon eaten. One sacred geno point gained…"" & @CRLF & _
""Black beetle killed. No beast soul gained. Eat the flesh of the black beetle to gain zero to ten geno points randomly."" & @CRLF & _
""Black beetle flesh eaten. Zero geno points gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Flesh of black beetle eaten. One sacred geno point gained."" & @CRLF & _
""Primitive creature green-scaled beast killed. No beast soul gained. Eat the flesh of the primitive green-scaled beast to gain zero to ten points randomly."" & @CRLF & _
""Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten points randomly."" & @CRLF & _
""Primitive creature swift mantis killed …"" & @CRLF & _
""Primitive creature copper-toothed beast killed. No beast soul gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Primitive creature copper-toothed beast killed. Primitive beast soul of copper-toothed beast gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."" & @CRLF & _
""Sacred-blood bloody slayer killed. Sacred-blood beast soul bloody slayer gained. Eat the flesh of bloody slayer to gain zero to ten sacred geno points randomly."" & @CRLF & _
""Primitive green-scaled beast flesh eaten. One primitive geno point gained."" & @CRLF & _
""Mutant copper-toothed beast killed. No beast soul gained. Eat its flesh to gain zero to ten mutant geno points."" & @CRLF & _
""Mutant copper-toothed beast flesh eaten. One mutant geno point gained."" & @CRLF & _
""Primitive creature quartz scorpion killed. No beast soul gain. Eat the flesh of quartz scorpion to gain zero to ten primitive geno points."" & @CRLF & _
""Primitive quartz scorpion flesh eaten. Four primitive geno points gained."" & @CRLF & _
""Young obsidian dragon eaten. One sacred geno point gained…"" & @CRLF & _
""Sacred-blood creature purple-winged dragon killed. Sacred-blood beast soul of purple-winged dragon gained. Eat the flesh of purple-winged dragon to gain zero to ten sacred-blood geno points randomly."" & @CRLF & _
""Sacred-blood copper-toothed beast killed. No beast soul gained. Eat its meat to gain one to ten sacred geno points randomly."" & @CRLF & _
""Meat of copper-toothed beast eaten. One sacred geno point gained."" & @CRLF & _
""Meat of copper-toothed beast eaten. One sacred geno point gained.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")