#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:http(s)?:\/\/)?(?:[\w]+\.)?linkedin\.com\/(?:pub|in|profile)?(?:\/*)([\w\-\.]*)"
Local $sString = "es.linkedin.com/pub/francisco-fernandez/30/14/62" & @CRLF & _
"https://www.linkedin.com/profile/view?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name" & @CRLF & _
"de.linkedin.com/pub/frank-rempp/1/638/7a1" & @CRLF & _
"http://uk.linkedin.com/pub/some-name/1/1b3/b45/" & @CRLF & _
"http://nl.linkedin.com/pub/other-name/11/223/544" & @CRLF & _
"http://www.linkedin.com/in/aname/" & @CRLF & _
"http://www.linkedin.com/in/another-name" & @CRLF & _
"http://linkedin.com/in/name" & @CRLF & _
"http://nl.linkedin.com/in/name" & @CRLF & _
"http://nl.linkedin.com/in/name/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)