$re = '/(\w+|"[^"]*")/';
$str = 'create myclass "56, \'for the better or worse\', 54.781"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);