using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}_[a-z0-9]+)_\d+$";
string input = @"DDD001_1_2016_6TP2_1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}