$re = '/(^\d+)\. /m';
$str = '1. Eulersche Identität
2. Das Euler-Produkt
10. Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);