$re = '/^[0-9]{10}$/m';
$str = '12345678908
1122557890
7878787808
888';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);