re = /([A-Za-z0-9.-]*)( at |@)([A-Za-z0-9.-]*)(\.| dot )([A-Za-z]{2,})/
str = 'something@virginia.edu
something at virginia.edu
something at Virginia dot edu '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end