re = /(?!(.*[^.])?\.([^.].*)?$)(?!.*\/{2})(?!.*\.{3})^[A-Za-z\/\.]*$/
str = 'aaa/asdasda/ad/a..da/..sdafdsf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end