package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<keep>[^};{]+)(?:{\s*}(?<koep>))?`)
var str = `.selector-with-statements{border:none;}.selector-without-statements{}.etc{}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}