package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)()()(\[[^\]\r\n]+\])\s*->\s*(\[[^\]\r\n]+\]\s*->\s*\[[^\]\r\n]+\])`)
var str = `[AAA] -> [BBB] -> [CCC]
AAA -> [BBB] -> [CCC]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}