const regex = /(?:\G(?!^)|\()[^)\s]*\K\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|\\()[^)\\s]*\\K\\s+', 'gm')
const str = `foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);