#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([^>]+)>([^<]+)<(\/\1)>"
Local $sString = "<h1>Nayeem loves counseling</h1>" & @CRLF & _
"<h1><h1>Sanjay has no watch</h1></h1><par>So wait for a while<par>" & @CRLF & _
"<Amee>safat codes like a ninja</amee>" & @CRLF & _
"<SA premium>Imtiaz has a secret crush</SA premium>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")