import Foundation
let pattern = #"(?=(?!^)\b\d+\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1) test 1 22) test 2 333) test 3 4444) test 4 55555) test 5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)